Zoom Software Client LifeCycle Management


Zoom Software Client LifeCycle Management


Zoom will be creating a Software Lifecycle management for their client. This will be a Quarterly updated minimum client version requirement for entering a Zoom Meeting or Webinar.

The Princeton Zoom Admin team will keep this resource updated with the latest information.



Zoom Client

Beginning November 5, 2022 Zoom’s required minimum client version for entering a Zoom Meeting or Webinar will be version 5.8.6.

This includes all major OS (Windows, MacOS, Linux, iOS, Android, Intune and Blackberry)

Find instructions for Keeping Your Client Up to Date



Zoom for Outlook Plugin

The Zoom for Outlook Plugin also needs to be updated to the version 5.8.6.

*It is recommended to use the Zoom Add-In instead of the Plugin.

For installing the Zoom Outlook PlugIn on a Windows machine, download from Zoom’s site the latest available version https://zoom.us/download

The Zoom for Outlook Plugin is not recommended for macOS users. Use instead the Zoom Add-in.

 

More Resources

Users can always find the latest information on the Princeton Zoom Central Page.